ปัญหาการอัพเดท i18n

พอดีวันนี้ได้ลองกลับเข้าไปแวะดูเว็บของทางคณะที่ผมทำไว้ด้วย drupal 7 เพื่อตรวจสอบการอัพเดทสถานะของโมดูลต่างๆว่ามีอะไรที่ต้องอัพเดทบ้าง หนึ่งในนั้นก็มีโมดูล i18n อยู่ด้วยผมก็ทำการอัพเดทตามปกติ แต่หลังจากสั่ง update.php เท่านั้นมันดัน error ฟ้องไม่ผ่านซะงั้น...งานเข้าครับ!!!

สำหรับคนที่ไม่รู้ว่า i18n คือโมดูลอะไร มันก็คือโมดูลที่ไว้สำหรับแปลภาษาของ drupal เพื่อทำเป็นเว็บไซต์สองภาษานั่นเอง ซึ่งสิ่งที่มันฟ้องกลับมาทำเอาผมงงเหมือนกันมันดันฟ้องว่า

Variable store (7.x-2.x) (incompatible with version 7.x-1.2)
Variable realm (7.x-2.x) (incompatible with version 7.x-1.2)

ลืม sceenshot error มาให้เห็นแต่ฟ้องประมาณนี้เละ -_- คราวๆก็คือมันบอกว่าประมาณว่ามึงขาดโมดูลตัวเวอร์ชั่นนี้อะกูอัพเกรดให้ไม่ได้หรอกนะ ผมก็เลยถามพี่กู(เกิ้ล)เอาและก็ได้วิธีแก้มาง่ายๆครับ

วิธีแก้ปัญหา variable error (7.x-2.x) ของ i18n

  1. สำรองฐานข้อมูลของเราก่อนเลยครับกันพลาด แนะนำโมดูล http://drupal.org/project/backup_migrate
  2. ftp เข้าไปยัง sites/all/modules/ แล้วลบ variable ทิ้งไปเลย
  3. โหลดโมดูล variable 7.x-2.1 มาใส่ใหม่
  4. ทำการ clear caches และสั่ง update.php ใหม่

Thank : http://www.document.sk/drupal-variable-update

Add new comment